Jump to content
Sign in to follow this  
SMichelle92

Implantation or period... confused

Recommended Posts

SMichelle92

I am having a really weird cycle and am confused! 
 

usually my cycles range from 28-30 days long.

I got positive ovulation test  on  15th October which was cycle day 15. 
on Sunday afternoon I felt a bit off, and then noticed when I went to the bathroom that I had some pinkish coloured spotting when I wiped. 
Stopped overnight. Then had a tiny bit again monday only in the morning and again stopped all day & started again in the evening.

today I got really bad pain in the morning & then I’ve continued to have light spotting mainly just when I pee.

so the spotting started day 25 of my cycle & has been on day 26 (only morning & evening) & today day 27. 

 

I think I’m about 11/12 days past ovulation. 
I’ve taken a pregnancy test which was negative and I’m pretty convinced now that my period is just coming really slowly and have no idea why it would randomly start spotting on day 25 instead of the usual time. If anything my period is usually late not early. 
 

I didn’t have any implantation bleed with my daughter & I tested positive with her 10DPO.

 

ive also been through two chemical pregnancies but those were when my cycle was very out of whack and I didn’t test positive until 14-16dpo and then went on to miscarry quickly. (this was before my daughter was born).

 

thoughts? Am I going crazy just wishing to be pregnant? 

 

 

 

 

 

Share this post


Link to post
Sweet.Pea

I have spotting before AF and it's fairly normal. The doctor said it could be hormonal or stress.

It could also be implantation and isn't showing on the test because there isn't enough HCG yet.

If you want to join our TTC group, we have moved - https://www.everybump.com.au/forums/viewtopic.php?f=2&t=21

Share this post


Link to post
blackcat20

I had on/off spotting alternating pink and brown for about four days before I got my BFP. First baby I had heavyish brown bleeding for four days when my period should have been due.

Share this post


Link to post
SMichelle92
2 minutes ago, blackcat20 said:

I had on/off spotting alternating pink and brown for about four days before I got my BFP. First baby I had heavyish brown bleeding for four days when my period should have been due.

 Thank you, it’s interesting to read what other people’s experiences with implantation bleeding have been. 
when I google I got a lot of varied answers with some websites saying it should be brown, some pink some saying very light and others saying it could last days or be like a light period.

I guess I just have to be patient and wait and see if it turns to a full blown period.

im already feeling like this evening the bleeding might be starting to get heavier :( 

Share this post


Link to post
lozoodle

Hopefully its good news!

 

But just want to check - you said bad pain and then spotting when you pee? Could be a UTI?

Share this post


Link to post
SMichelle92
41 minutes ago, lozoodle said:

Hopefully its good news!

 

But just want to check - you said bad pain and then spotting when you pee? Could be a UTI?

Hopefully but I’m doubtful.

I mean I had bad period cramping, I felt like for sure my period would full on start with the cramping but it didn’t.

and I’m mainly getting blood when I wipe, no pain or anything when I pee! But thanks for the concern :) 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...